PHP is amongst the most commonly used imperative programming languages. It is highly popular because it’s free software, which you can use to build interactive sites like social networking websites, online shopping portals or e-teaching sites instead of static HTML-based sites. A PHP module must be enabled on the web server where a PHP website is hosted so that its PHP code can be ‘decrypted’. Because there are no license taxes for this type of module and the language itself offers limitless possibilities for the web applications that you build, there are hundreds of millions of PHP-driven sites. Additionally, there are an immense number of PHP scripts, which you can use for your sites without needing to have any programming skills. Since there are different versions of PHP, you ought to check if the very same version that you used while creating your website is enabled on the server too.
PHP 4, PHP 5 and PHP 7 Support in Web Hosting
With our web hosting, you will be able to pick the version of PHP that will be active for your shared web hosting account, as multiple versions are installed on our servers. With as little as one click, you will be able to switch between PHP 4, 5, 7 and anytime a new version is unveiled in the future, we’ll add it to the Hepsia hosting Control Panel without removing the previous ones. Thus, you will be able to host all the sites that you have set up over the years. In contrast with many other web hosting companies, we won’t force you to update such sites, because a script may be outdated, but this does not mean that it’s vulnerable as you may have done modifications to its source code to fill security loopholes. For your convenience’s sake, you’ll even be able to specify a different PHP version for each individual website that you host in your hosting account.
PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers
In case you have a website created using a previous PHP version and you have devoted time and effort toward setting it up, patching safety gaps and publishing content, you’ll need a hosting service that can support it, as the great majority of hosting vendors nowadays offer support only for the most recently launched version of PHP and drop the earlier versions. We, on the other hand, have decided to permit you to select the exact version that your own sites need. Our semi-dedicated servers support PHP 4, PHP 5 and PHP 7, so you will be able to use both newer and older scripts without forfeiting any customizations or misspending time struggling to make your sites compatible with the web hosting platform. The current version can be changed via the Hepsia Control Panel and such an update will apply to the entire semi-dedicated server account, but you’ll also be able to pick a different PHP version for each site that you host in your account using an .htaccess config file.